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Abstract 

This document is a printable version of the Interaction Desktop framework online help. It explains the 
Interaction Desktop interface. Online help is available within Interaction Desktop by selecting Get 

Started or CIC Client from the Help menu. 
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Interaction Desktop 

Get started with Interaction Desktop 

Important: Customer Interaction Center (CIC) supports two interaction management client 
applications. This documentation uses the term "CIC client" to refer either Interaction Connect or 
Interaction Desktop. The full product name appears at the top of each help topic. The full product 
name may also be used in a help topic when necessary to distinguish between CIC clients. 

Interaction Desktop provides a user interface for easy access to the features of application modules such 
as the CIC client. For help with a specific area within a Workspace, click anywhere in the Workspace and 

press F1. For help with CIC client, from the Help menu, select Interaction Client. 

Related Topics 

Interaction Desktop interface 
Log on 
Modules 
Menus 
Navigation pane 
Toolbars 
Views 
Workspaces 

CIC 2019 R1, August 30,2019 

Feedback, support, and other information 

Options on the Interaction Desktop Help menu enable you to learn more about Genseys products and 
promote or share ideas about Genesys software. You can also access technical support or submit 

feedback about bugs and enhancement requests. 

Note: You must have Internet access to visit the Genesys website or submit feedback. 

Need Help? 

Click Help > Getting Started to display help for the framework. This includes help for creating and 
configuring workspaces and views. 

Click Help > CIC client to display help for CIC client features and views. 

Note: A printable version of the CIC client help is available on the Genesys website at 
https://help.genesys.com/cic/desktop/printable_documentation.htm  

Using the Search Feature 

You can search for specific terms in the help. There is a basic search and an advanced search available 
from the Search tab. 

A basic search is simple: just type whatever single word or phrase you want to search, press Enter or 
click the List Topics button (HTML version only). A list of topics containing that word or phrase appears. 
When searching for a phrase, use quotation marks to enclose the phrase. For example, use “directory 

toolbar” to return only topics that contain that exact phrase. 

https://help.genesys.com/cic/desktop/printable_documentation.htm


 

 

Some basic facts 

• All the words you enter in the search box are used in the query. 

• The search is always case-insensitive. A search for [dtmf] is the same as a search for [DTMF]. 

• Generally, punctuation is ignored, including @#$%^&()=+[]\ and other special characters. 

An advanced search involves wildcard (HTML version only) and Boolean expressions. Wildcard 
expressions allow you to search for one or more characters using an asterisk or question mark. Wildcard 

search examples: 

Search Term(s) Returns... 

init* initial, initiate, etc. 

1?3 123, 133, 143, etc. 

Boolean searches involve the use of “OR”, “AND”, and “NOT”. Boolean search examples: 

Search Term(s) Returns... 

alert AND configuration Topics containing both the words "alert" and "configuration" 

conference OR chat Topics containing the word “conference” or “chat” or both 

speed NOT dial Topics containing the word “speed” but not the word “dial” 

Feedback and PureConnect Customer Care 

Options on the Help menu enable you to learn more about Genesys products, promote and share ideas 
about PureConnect software, access technical support, and submit feedback about bugs and 
enhancement requests. 

Note: You must have internet access to visit the Genesys website or submit feedback. 

• To visit the Genesys home page, go to http://www.genesys.com. 

• To access the PureConnect Customer Care website, go to 

https://www.genesys.com/inin/about/services/support-services. 

Note: You must log on to this site before you can access technical support. 

• To visit the PureConnect Community Forum, go to http://community.inin.com. 

Note: The PureConnect Community Forum is a free and public service provided by Genesys to 
promote an online community devoted to the sharing of ideas and information regarding 
PureConnect software. 

http://www.genesys.com/
https://www.genesys.com/inin/about/services/support-services
http://community.inin.com/


 

 

• Use our social media/crowdsourcing site to submit ideas for enhancing Genesys products. Vote 
on which ideas submitted by others best describe the enhancements you want. Go to 

http://ideas.inin.com. 

• To submit documentation feedback, do one of the following: 

• If you have a comment or question about a specific help topic, click the Send Feedback 
link at the top right of that topic. 

• Send an email message to PureConnectDoc@genesys.com. 

Log on, log off, or exit 

Log on 

Log on to a secure system 

1. Do one of the following: 

• From the Windows Start menu, select PureConnect > Interaction Client. 

• Double-click the Interaction Desktop icon on the Windows desktop or taskbar. 

Result: The Interaction Desktop log on dialog appears. 

2. In the Interaction Desktop Logon dialog box, make any necessary adjustments to your logon 
settings.  

3. Click Log On. 

Result: In a secure system, a User Agreement dialog box similar to this one appears. 

 

Related Topics 

Logon dialog box 
Logon connection settings 

http://ideas.inin.com/


 

 

Single sign-on 

Log on automatically 

An automatic logon uses the default profile (Default.ininprofile) or default settings. The default settings 
use Windows authentication, the default server, and the computer name as the workstation name. 

Note: You cannot log on automatically on a secure system. 

• Click the Interaction Desktop icon on the Windows desktop or taskbar. 

Result: This action logs you on automatically and displays Interaction Desktop. 

Related Topics 

Log on to a secure system 
Logon connection settings 

Select a profile and log on 

1. From the Start menu, select PureConnect > Interaction Client. 

Result: The Interaction Desktop log on dialog appears. 

Tip: Point to the Profile icon (folder). The tooltip displays the name of the currently loaded 

profile. 

2. Do one of the following: 

• To change your current logon settings or to create an alternate startup configuration, 

proceed to the next step. 

• To use or change an existing set of logon settings, click the drop-down arrow next to the 

Profile (folder) icon. Select Load Profile. Find the appropriate profile and click Open. 

• To use the settings, click Log On. 

• To change the settings, proceed to the next step. 

3. In the Connection tab, adjust your logon settings. 

4. Optionally, on the Options tab, select another language for the CIC client interface and help. 

5. If you changed any settings, click the drop-down arrow next to the Profile (folder) icon. Select 

Save Profile As. 

Result: The Save As dialog box appears. 

6. If you changed any settings, do one of the following: 

• If you selected an alternate profile in step 2, verify that the appropriate name appears in 
the File name drop-down list box and click Save. 

• To change your default settings, in the File name drop-down list box, select 
Default.ininprofile and click Save. 



 

 

• To create a set of logon settings, in the File name drop-down list box, enter a new file 
name in this format: filename.ininprofile Click Save. 

7. Click Log On. 

Related Topics 

Logon connection settings 
Logon options 
Logon dialog box 
Logon profiles 

Select a language 

If your Customer Interaction Center (CIC) administrator has installed the appropriate language pack on 
the CIC server, you can select a language other than English for the Interaction Desktop interface and 
help. 

Note: This setting is independent of the Microsoft Windows Regional and Language Options setting. 
It is available only when a Language Pack has been installed on the CIC server. 

To select a language: 

1. In the Logon dialog box, do one of the following: 

• To change your current log on settings or to create an alternate startup configuration, 
proceed to the next step. 

Tip: Point to the Profile icon (folder). The tooltip displays the name of the currently 
loaded profile. 

• To change an existing set of log on settings, click the drop-down arrow next to the 
Profile (folder) icon. Select Load Profile.  Find the appropriate profile and click Open. 

2. In the Options tab, from the Language drop-down list, select the appropriate language for the 
Interaction Desktop interface and help. 

Note: This setting is independent of the Microsoft Windows Regional and Language Options 
setting. It is available only if your CIC administrator installed one or more Language Packs on 
the CIC server. 

3. Click the drop-down arrow next to the Profile (folder) icon. Select Save Profile As. 

4. In the Save As dialog box, do one of the following: 

• If you selected an alternate profile in step 1, verify that the appropriate name appears in 
the File name drop-down list box and click Save. 

• To change your default settings, in the File name drop-down list box, select 
Default.ininprofile and click Save. 

• To create a set of log on settings, in the File name drop-down list box, enter a new file 
name in this format: filename.ininprofile Click Save. 

5. To test your configuration changes by logging on to Interaction Desktop, in the Logon dialog box, 
click Log On. 



 

 

Related Topics 

Logon dialog box 
Logon options 

Logon profiles 

Interaction Desktop automatically creates a default profile the first time you log on. This profile contains 
the default settings for future logons. If you use your default profile when you log on, Interaction 
Desktop saves any changes you make to these settings. 

You can create alternate profiles for different users who share a workstation or remote users who use 
different workstations to log on. 

Note: You can select a profile only when you start Interaction Desktop. You cannot use a profile if 
you log off but do not exit Interaction Desktop and then use the File menu to log on again. 

Tip: You can create a profile and add the profile (or a shortcut to it) to the Windows Startup folder 
so Interaction Desktop starts automatically when you start your computer. 

Related Topics 

Select a profile and log on 

Logon connection settings 

To enter authentication details and server connection information, use the Logon dialog box. If you need 
more information about these settings, contact your Customer Interaction Center (CIC) administrator. 

Note: If you have forgotten your CIC password, contact your CIC administrator. Your CIC 
administrator can reset your password in Interaction Administrator. Contact your system 

administrator if you use a Windows user ID and password or an alternate identity provider. 

Tip: You can save and use multiple sets of logon settings in profiles. 

Use Windows 
Authentication 

To log on to Interaction Desktop using your Windows user ID and 
password, select this check box. 

Note: The CIC administrator must first enable this option by 
allowing Windows authentication and by linking Windows user 
names and CIC user names. 

Credentials This drop-down list appears only if your CIC administrator has enabled 
the Single Sign On feature. The Single Sign On feature automatically 
uses your secure system user ID and password to log you on 

automatically to Interaction Desktop. 

Select the appropriate set of credentials from this drop-down list. 

Logged-On User 

To log on using the Windows user name and password you used 
to log on to your workstation, select this option. 



 

 

Customer Interaction Center 

Log on using your CIC user ID and password. 

Alternate Windows 

Log on using a Windows user name and password that is 

different from the one used to log on to your workstation. 

For example, a supervisor could log on to Interaction Desktop 

on your workstation in order to assist you. 

(other) 

Other Identity Providers could appear in this drop-down list. 
Contact your CIC administrator for more information about 

using these credentials and providing a User ID and password. 

User Enter the name of your user account: 

• If you selected Use Windows Authentication or are using Logged-
On user credentials, you do not need to enter your user name. 
This field is unavailable. 

• If you are using Customer Interaction Center credentials, User is 
the name of your account as configured in Interaction 
Administrator. To verify your user account name, contact your CIC 
administrator. 

• If you are using Alternate Windows credentials in a Single Sign On 
system, type a user name that is different from the one used to log 
on to the workstation. 

This user name can include a domain name in the format 
domain\username or user@domain. Include a domain name if these 
alternate credentials belong to a different domain than the one for 
the credentials used to log on to the workstation. 

Password Some secure systems require you to enter your password every time 
you log on. If prompted, enter the appropriate password: 

• If you are using Customer Interaction Center credentials, enter 

your CIC user account password. 

Note: If you have forgotten your password, contact your CIC 
administrator. 

• If you selected Use Windows Authentication, enter your Windows 
password. 

• If you are using Logged-on user credentials in a Single Sign On 
system, you do not need to enter your password. 



 

 

• If you are using Alternate Windows credentials in a Single Sign On 
system, type the password associated with this alternate Windows 

account. 

Save Password 

or 

Save Credentials 

Select this check box if you do not want to enter your password each 
time that you log on to Interaction Desktop. 

Note: The CIC administrator must first enable this option by 
allowing the use of cached credentials. The saved password is only 
valid for this computer and this log on. For example, you cannot 
use the encrypted password in this profile on a different computer. 

Server Enter the name of the appropriate server. This server is the machine 
running Session Manager. For most installations, this server is the CIC 
server. 

Station Type This station is the one you use to run Interaction Desktop. 

<this computer> 

Select this option if you move around the office and log on from 
different local workstations. 

This option ensures that CIC routes your calls to the station 
associated with this computer, not the last workstation to which 
you logged on. 

Note: When you use this option, the name of the current 
station appears in Workstation. 

Workstation 

Use a computer and telephone connected by a telecom outlet 
(SIP or analog phone) to CIC. 

Remote Station 

Work from a "known" single remote location, a configured 
Remote Station, using a single phone number for all calls to the 
agent’s extension. 

Remote Number 

Work from an ad-hoc remote location, a dynamic remote client 
connection, using a single phone number for all calls to the 
agent’s extension. 

SIP Soft Phone 

Use the computer as the telephone. (Also called a soft phone.) 

Note: Your CIC administrator must appropriately configure 
your station in Interaction Administrator. This configuration 



 

 

requires the SIP Soft Phone application and a supported USB 
audio device. 

Workstation If you select Workstation, Remote Workstation, or SIP Soft Phone as 
your station type, enter the name of the workstation here. If you select 
Remote Number, then this field is unavailable. 

Remote Number For remote access only, enter the telephone number CIC uses to call 
the agent. 

Note: If you enter a Remote Number, it appears in the status bar in 
place of your Station name. 

Persistent Requirements: Some secure systems do not allow persistent 
connections. 
 
You need the Persistent Connections Security Right to select a 
persistent connection when you are using a dynamic remote client 
connection. 
 
If you are using a configured remote station, the Station Connections 
are Persistent setting in Interaction Administrator Station 
Configuration controls whether you have a persistent connection. 

• If you select this option, the connection to the CIC remains 
connected from the first time you require a voice connection 
until you log off the system. 

• If you do not select this option, CIC ends calls to your remote 
phone when either side disconnects for any reason. 

Example: The first time a remote agent receives a call or requires a 
voice connection, CIC calls the agent at the phone number in the Logon 
dialog box. 

From that point on, the agent can keep the telephone handset off-hook 
and use the CIC client to pick up, disconnect, and listen to calls or to 
record prompts. If the agent hangs up between calls, CIC must redial 
the agent’s telephone and wait for the agent to answer before 

completing the operation. 

Explanation: When you select Persistent, the call to your remote phone 
stays connected (an open line to the CIC server). If you leave the 
remote phone off-hook, and disconnect using the CIC client, CIC does 
not have to create a new call and dial your remote phone again. It just 

connects the audio path to the new caller. 

Note: Usually this preferred setting prevents excessive long-

distance charges and keeps lines free. 



 

 

Folder icon This icon and its associated drop-down list enable you to load a 
different profile or save settings as a new profile. 

The first time you start Interaction Desktop, it creates a default profile 
called Default.ininprofile. Instead of using the default profile, you can 
use the Save Profile As option to save the file to your desktop or 
another convenient place. When you double-click that file, you bypass 

the Logon dialog box and connect to Interaction Desktop. 

Save Profile As 

In the Save As dialog box, type a profile name in the File name 
box. Use the format filename.ininprofile for the file name. You 
can save the profile to your desktop, and double-clicking it 
automatically logs you in. This method bypasses the Logon dialog 
box. 

Tip: You can create a profile and add the profile (or a shortcut 
to it) to the Windows Startup folder so Interaction Desktop 

starts automatically when you start your computer. 

Load Profile 

If you want to open a profile other than the default profile 
(default.ininprofile), select Load Profile and select another 
profile. You can also right-click an ininprofile file and select Edit 
to open up the Logon dialog box to change settings. 

Related Topics 

Log on 
Logon dialog box 
Remote logon 
Remote station types 
Select a profile and log on 

Logon options 

Use the Options tab of the Logon dialog box to select a language. You can also save or use multiple log 
on configuration settings (profiles). 

Note: In order to select a language, your CIC administrator must first install the appropriate 
language pack on the CIC server. 



 

 

 

Related Topics 

Logon connection settings 
Select a language 
Select a profile and log on 

Logon dialog box 

The Logon dialog box enables you to edit and save your preferred authentication details, server 
connection information, and other startup settings. 

 

Note: If your Customer Interaction Center administrator has enabled the single sign-on feature, the 
appearance of your Logon dialog box may be different. Contact your CIC administrator for logon 

instructions. 



 

 

Tip: Click the Help icon on the Connection or Options tabs if you have questions about any of the 
required entries. 

Related Topics 

Logon connection settings 

Single sign-on 

Single sign-on enables you to log on to Interaction Desktop using credentials certified by any identity 
provider designated by your Customer Interaction Center (CIC) administrator. Typically, you log on to 
your workstation, a network domain, or some other secure system before you log on to Interaction 
Desktop. This initial logon procedure prompts you for a user ID and password. Interaction Desktop uses 
these same credentials to log you on automatically — without prompting you to enter the credentials 

again. 

If your CIC administrator enables the single sign-on feature, the appearance of the Logon dialog box is 

slightly different, although most of the settings are the same. 

Related Topics 

Logon connection settings 
Logon dialog box 

Command-line parameters 

Interaction Desktop supports optional command-line parameters (switches) that you can use when 
starting Interaction Desktop. A shortcut typically contains these parameters. Command-line parameters 
are not case-sensitive. 

Parameter 
Abbreviatio
n 

Description Example 

-fullscreen None 
Opens the application in full 
screen mode. 

-fullscreen 

-user -u 
Allows you to specify the 
user logon name. 

-user john.doe 

or 

-u john.doe 

-pass -p 

Allows you to enter the 
Customer Interaction Center 
(CIC) password specified in 

Interaction Administrator. 

-pass 1234 

or 

-p 1234 

-
windowAuthenticatio
n 

-winauth 
Uses the Windows 
Authentication for logon. 

-windowAuthentication 

or 

-winauth 



 

 

-server 

or 

-notifier 

-n 

Specifies the CIC server to 
which you connect 
Interaction Desktop. You can 
specify the CIC server name 
or IP address. 

-notifier DevIC1 

or 

-n 204.180.46.8 

or 

-server ICSvr1 

-silent 

or 

-lastlogin 

None 

Logs on to Interaction 
Desktop using the credentials 
entered in the most recent 
logon, without prompting for 

logon information. 

-silent 

or 

-lastlogin 

-login None 

Opens the Logon dialog box 
even if you specify user, 
password, and server 
parameters. 

-login 

-
ForceCorrectTabOrde

r 
None 

Disables the "menu mode" 
on toolbars which allows for 
correct tab order though all 
views, menus, and toolbars 
at the expense of some 
toolbar functionality. 

For example, with "-
ForceCorrectTabOrder" 
enabled, the user can Tab or 
Hot Key to the"Disconnect" 
toolbar button, and then Tab 
or Hot Key back to the "Enter 
a name or number to dial" 
field. But the 
Cut/Copy/Paste/Delete 
toolbar buttons will no longer 

work correctly. 

-ForceCorrectTabOrder 

-
accessibilitycomplian
t 

None 

Adds these features to 
accessibility compliance: 

• Enabled toolbar 
button names  in 
views such as My 
Interactions appear 
in high contrast, 

-
accessibilitycompliant=Tr
ue 



 

 

making them easier 
to see and read. 

• The screen reader 
fully describes a 
selected interaction 
(name, number, 
state, etc.). Without 
this, the screen 
readers describes a 
selected interaction 
only by number; for 

example 1 of 3. 

• A dialog appears 
when no records are 
found in a search in 
the Company 
Directory or Call 
History views. The 
screen reader 
announces no 
records were found if 
a search fails to find 
matching records. 

Note: This can be 
overridden by the 
command line argument 
InteractionDesktop.exe -
accessibilitycompliant=tr
ue (or false). 

Example shortcut 

For example, if the name of your CIC server is ICSvr1, your Customer Interaction Center User ID is 
John.Doe, and your password is PW1234, the command line would read: 

"C:\Program Files\InteractiveIntelligence\InteractionDesktop.exe" –u 
John.Doe –p PW1234 –n ICSvr1 

A space separates command-line arguments. If you prefer to use the verbose form of the command-line 
switches, the same command line would be: 

"C:\Program Files\InteractiveIntelligence\InteractionDesktop.exe" –
user John.Doe –pass PW1234 –notifier ICSvr1 

or 

"C:\Program Files\InteractiveIntelligence\InteractionDesktop.exe" –
user John.Doe –pass PW1234 –server ICSvr1 

Related Topics 



 

 

Log on 

Remote logon 

You can run Interaction Desktop from a remote location. If you work at home or travel for work, you can 
receive regular and ACD-routed incoming interactions. You can also use all the other CIC client features. 

Logging on remotely is similar to logging on from an office workstation. Pay particular attention to 

Station Type, Remote Number, and Persistent settings in the Logon dialog box. 

For more information, see the Interaction Desktop help in the CIC Client part of the PureConnect 

Documentation Library. 

Related Topics 

Answer the first call to a remote location 
Call from a remote location 
Interaction Desktop and remote locations 
Log on 
Logon connection settings 
Logon dialog box 
Remote station types 

Answer the first call to a remote location 

Once the CIC client starts and the remote agent’s status is available, incoming calls alert only on the 
workstation. The agent’s telephone does not ring at the same time the call alerts the CIC client. The first 
time CIC sends a call to an available remote agent can be different from subsequent calls, depending on 
how the agent ends the first call. 

Remote agents who take campaign calls from Interaction Dialer must not hang up the handset between 
calls to avoid delays talking to the next called party. Remote ACD agents must also keep the handset off-
hook after the first call from CIC. The handset must remain off-hook if the configuration specifies that 
calls connect automatically to the first available agent without the agent clicking the Pickup button. 

Campaign calls are outbound calls placed by Interaction Dialer. A campaign is a collection of properties 
that tell Interaction Dialer how to process the database table that contains telephone numbers and 
other information. For more information, see Interaction Dialer.  

To answer the first call from CIC after logging on: 

1. Do one of the following: 

• With the alerting call selected, click the Pickup button in a CIC client queue view. 

• Double-click the alerting call in a CIC client queue view. 

2. When the telephone rings, pick up the handset to speak; CIC immediately connects the call. 

3. When the call is over, do one of the following: 

• Click the Disconnect button and keep the handset off-hook. CIC automatically keeps a 
persistent connection to remote agents. As soon as you click the Pickup button on 
subsequent calls, the call connects immediately without waiting for the phone to ring. 

https://help.genesys.com/cic/mergedProjects/wh_dlr/desktop/interaction_dialer_2015.htm


 

 

• When the call is over, hang up the handset. In this case, CIC must redial the remote 
number to complete subsequent calls. 

Related Topics 

Call from a remote location 
Interaction Desktop and remote locations 
Remote logon 
Remote station types 

Call from a remote location 

Once the CIC client starts, remote agents can call any authorized phone number. Customer Interaction 
Center (CIC) dials the agent’s number and then dials the destination number. As soon as the dialed 

number starts alerting, CIC calls the agent’s telephone. 

To call: 

1. Enter or select a phone number in the CIC client and click the Make Call button. 

Result: CIC dials the agent then the number, and if it completes the call, it immediately connects 
it to the remote agent’s telephone number. 

2. Do one of the following: 

• If the handset is on-hook, when the telephone rings, pick up the handset to speak; CIC 
immediately connects the call. 

• If the handset is off-hook, listen for the called party to answer. 

3. When the call is over, do one of the following: 

• Click the Disconnect button and keep the handset off-hook. CIC automatically keeps a 
persistent connection (based on this logon setting) to remote agents. The agent can 
make multiple calls without hanging up the handset. Calls connect immediately without 
waiting for the phone to ring. 

• When the call is over, hang up the handset. In this case, CIC must redial the remote 
number to complete subsequent calls. 

Related Topics 

Answer the first call to a remote location 
Interaction Desktop and remote locations 
Remote logon 
Remote station types 

Remote station types 

Customer Interaction Center (CIC) supports two types of remote stations: dynamic and configured 
(static). Each type of remote station connection serves a slightly different purpose, depending on the 
needs of the call center and of the remote agent. Both provide the same CIC client functionality. 

Dynamic remote client connections (remote number) 



 

 

Requirements: In order to use a dynamic station, you need the appropriate rights. The Persistent 
Connections Security Right enables you to select a persistent connection when you are using a dynamic 
remote client connection. The User-defined Telephone Number on Remote Logon Security right 
enables you to enter a new Remote Number when logging on. 

Note: When using a dynamic remote client connection, select Remote Number as the Station Type 
when logging on to Interaction Desktop. 

Dynamic remote stations enable traveling agents to connect to CIC and place or receive calls from any 
remote location. These stations provide maximum flexibility for agents who work from ad-hoc locations 
and phone numbers. When these remote agents start Interaction Desktop and log in to CIC, they enter a 

desktop phone or cell phone to which CIC routes their calls. 

Dynamic remote stations do not have predefined station names in Interaction Administrator. The 
telephone number given when the agent starts Interaction Desktop and logs in to CIC is the remote 
station. CIC routes calls for that user’s extension to the remote phone number. 

Configured remote stations (remote workstation) 

Requirements: You need the User-defined Telephone Number on Remote Logon Security Right to use a 
configured remote station and specify a different remote phone number when logging on to Interaction 
Desktop. 
 
This option is usually selected by default for all users. If an agent does not have this right, the 
administrator specifies the configured remote station user’s remote phone number is in the Remote 
Station Configuration dialog in Interaction Administrator. 

Note: If you use a configured remote station, select Remote Workstation as the Station Type when 
logging on to Interaction Desktop. 

The administrator configures a remote station as a “remote station” type of workstation with a single 
remote phone number for all calls to the remote agent’s extension. Configured remote stations ensure 
that the remote agent always connects to CIC using the same remote phone number. Unless the CIC 
administrator changes it, or unless that user has the right to change the number dynamically. Some call 
centers prefer this approach, to ensure that remote agents are working from the prescribed location. 
The CIC administrator retains the option of granting flexibility to the agents who need it. 

The remote station name can be the same as the remote agent’s computer name, or it can be another 
name. The CIC administrator is responsible for creating these remote station workstations and educating 
the remote agent on how to use the Logon dialog box to enter a remote station name. 

SIP stations are not remote 

CIC does not classify remote agents who use a SIP-enabled device or IP phone to receive calls as dynamic 
or configured “remote stations.” SIP devices or phones connect directly to CIC with an IP-based network 
connection. Distance or location with a SIP device or phone has nothing to do with its classification as a 
remote station. 

The CIC administrator configures each SIP device or phone as a “local” workstation type of station in 
Interaction Administrator. This connection type is “SIP,” instead of a connection type of “Line” used for 
analog phone workstations. The configuration specifies the SIP address of the computer, which must be 
on the same domain or trusted domain as the CIC server. Some “remote” agents with SIP devices or 



 

 

phones use a VPN connection over the Internet to connect to the domain, log on to CIC, and run 
Interaction Desktop. In any case, CIC classifies these stations as local workstations. 

Remote station licenses 

Even though the CIC administrator does not configure dynamic remote stations in Interaction 
Administrator, each dynamic station connection counts toward the total number of station licenses "in 
use." CIC adds the current dynamic station connections to the number of configured stations (remote 
stations, workstations, stand-alone phones) that are "Active." This total is the number of active stations. 
If a remote agent attempts to start the CIC client and log on to CIC when the total number of station 
licenses are in use, that agent cannot connect. The agent sees an error message indicating that no 

stations are available. An error message also appears in the Event Log on the CIC server. 

Related Topics 

Answer the first call to a remote location 
Call from a remote location 
Interaction Desktop and remote locations 
Remote logon 

Interaction Desktop and remote locations 

If the Customer Interaction Center (CIC) administrator configured the remote workstation always to ring 
the telephone, the CIC automatically alerts the station and rings the remote telephone. To answer a call, 
the remote agent picks up the handset to connect to the call. Once the phone is off hook and connected 
to CIC with a persistent connection, the remote agent can dial directly from the phone keypad or from 

the CIC client. 

Keep a persistent connection to the CIC server 

CIC detects when it must call a remote agent’s telephone or when it already has a (persistent) voice 
connection to a remote agent. If you selected Persistent in your Logon connection settings or if the 

remote station configuration requires it, CIC keeps the connection open once you establish it. 

For example, the first time a remote agent receives a call or requires a voice connection to the CIC 
server, CIC calls the agent. CIC uses the phone number used on the agent’s Logon dialog box. From that 
point on, the agent can keep the telephone’s handset off-hook and use the CIC client interface to pick 
up, disconnect, and listen to calls or to record prompts. With the voice connection already established, 
these operations are instantaneous. If the agent hangs up between calls, CIC must redial the agent’s 
telephone and wait for the agent to answer before completing the operation. 

Note: If the CIC server restarts or switches to a backup server, the remote agent’s current call could 
disconnect. 

Related Topics 

Interaction Desktop and remote locations 
Logon connection settings 
Remote logon 
Remote station types 

Log on 



 

 

There a several ways you can log on to Interaction Desktop. To log on automatically or use profiles to log 
on, your Customer Interaction Center (CIC) administrator must allow the use of cached credentials. 

Some CIC administrators prevent automatic logon for security reasons. 

One Station at a Time 

Requirements: You need the Station Logon Access Control right to a specific station to be able to log on 
to it. 

You can log on to only one station at a time, for security reasons. 

• If you try to log on to two different stations, CIC drops the original station connection. For 
example, if you try to run Interaction Desktop at the same time you are running Interaction 
Connect on a different station, the original connection drops. 

• If two different users try to log on to the same station from two different computers, the first 
user connects, the second doesn't. 

Related Topics 

Command-line parameters 
Log on automatically 
Log on to a secure system 
Logon connection settings 
Logon dialog box 
Logon options 
Select a language 
Select a profile and log on 
Single sign-on 

Log off 

To log off Interaction Desktop and keep the application open, click File > Log off. 

Note: If the station associated with the telephone is your default workstation in Interaction 
Administrator, your non-ACD calls ring on your telephone when you log off Interaction Desktop. 
Otherwise, the system announces to callers that you are not available. 

Related Topics 

Exit 
Log on 

Exit 

To exit Interaction Desktop: 

• Click File > Exit. 

Note: In Windows 7, clicking the X in the upper-right corner of Interaction Desktop minimizes the 

application or hides it, depending on the configuration setting in the CIC client General Options. 

Related Topics 

Change your password 



 

 

Log on 
Log off 

Change station 

You can change your station to route your calls to another phone. You do not need to log off and then 
log back on to change your station. 

Note: Interaction Desktop saves the logon settings associated with each station type you use. These 
settings appear as defaults when you change station. 

1. Do one of the following:  

• Click your Station in the status bar. 

• Click File > Change station. 

2. In the Change Station dialog box, complete the required fields. These settings are the same as 
the Logon connection settings. 

3. Click Change Station. 

Related Topics 

Logon connection settings 
Remote station types 
Status bar 

Change password 

You do not need to wait until Interaction Desktop prompts you to change your password. You can 
change your password at any time. 

Note: The Change Password dialog box enables you to change your CIC password. It does not apply 
to your Windows password, even if you use your Windows User ID and password to log on to the 
CIC client. If you have forgotten your CIC password, contact your CIC administrator. Your CIC 

administrator can reset your password in Interaction Administrator. 

1. Click File > Change Password. 

 

2. Type your old and new passwords. 



 

 

3. Click the Change Password button. 

Related Topics 

Log on 
Password policies 

Password Policies 

Your Customer Interaction Center (CIC) administrator creates and assigns Password Policies to users. 
Password policies determine: 

• How often you must change your CIC password. 

• Minimum password length, number of required unique characters, and whether you can use 

sequential digits. 

• How often you can reuse a password and other password restrictions. 

Note: You need a valid CIC user ID and password to use Interaction Desktop, even if you use your 
Windows ID and password or other acceptable credentials to log on. 

Related Topics 

Change your password 
Single sign-on 
Windows authentication 

Interface basics 

Interaction Desktop interface 

Interaction Desktop provides a user interface for easy access to the features of application modules. The 
interface includes navigation panes, menus, toolbars, Workspace tabs, and a workspace. 



 

 

 

  

1 Title bar The title bar appears on the main Interaction Desktop window. 

2 Menu bar Menus organize the Interaction Desktop commands and actions you 
can use when working with program modules. 

3 Toolbar area The Interaction Desktop toolbar area contains several smaller 
toolbars that you can show or hide. 

Note: Individual views can contain their own toolbars. 

4 Standard 
toolbar 

Add new views or workspaces to Interaction Desktop. Use the 
standard editing tools for cut, copy, paste, and delete in text boxes. 

5 Status toolbar View or change your Customer Interaction Center (CIC) status. This 
toolbar also displays how long you have spent in your status. You can 

add status notes to provide more information about your status. 

6 Workgroup 
Activation 

toolbar 

Select or clear activation status check boxes for the workgroups to 
which you belong. 



 

 

7 Make Call 
toolbar 

Call by typing a phone number. Lookup and dial a number from your 
Company Directory by typing part of the contact’s name. Or, click the 
drop-down arrow to choose from a list of names and numbers you 
have recently called. 

8 Processes 
toolbar 

Search for and start an Interaction Process. 

9 Workspaces The selected tab identifies the currently displayed workspace. To 
switch between workspaces, click a tab. 

10 Navigation Pane The Navigation Pane provides easy access to the module components 
in the default workspace or built-in workspaces. Module components 

appear as views in a workspace. 

Note: This feature is reserved for future use. For the CIC client 

which uses custom workspaces, the Navigation Pane is empty. 

11 Workspace The currently displayed workspace. 

12 Status bar The status bar displays your current connection state, server name, 
station name, voice mail indicator, and notifications. 

13 Connection 
state 

If disconnected, click this section to reconnect. If connected, point to 
this section to display your User ID, CIC server name, and Session 
Manager server name. A lock icon indicates that the connection is 
encrypted. 

14 Station 
or 
Remote number 

Displays the name of your currently active workstation or your 
remote number. 

Note: If you are using a dynamic remote client connection, the 
display version of your remote telephone number appears here. 
If you are using a configured remote station, the phone number 
entered by the CIC administrator appears here. 
 
The display version of a phone number is the result of conforming 
your phone number entry to the requirements of the dial plan for 
your organization or region. 

Tip: To change stations, click this section. 

15 Voice mail 
indicator 

If you have one or more unheard voice mail messages, this icon is in 
color. If the icon appears dimmed, you do not have any voice mail 
messages. 



 

 

16 Show in Mini 
Mode 

To display the CIC client in Mini Mode, click this control. 

17 Notification 
area 

CIC administrators can use client memos to communicate with 
selected users, workgroups, or roles. The administrator creates these 
client memos in Interaction Supervisor. These memos appear in the 
notification area or as desktop pop-ups (toast) in the lower right side 
of your Windows desktop. 

Tip: To display a tooltip that lists all your client memos, point to 
the notification area. 

  

Related Topics 

Change station 
Menus 
Navigation pane 
Remote logon 
Remote station types 
Status bar 
Toolbars 
Using Mini Mode 
Views 
Workspaces 

Menus 

Menus organize the commands and actions you can use when working with program modules. Available 
commands and actions vary according to the active module. 

From the menu bar, click a menu title to display a list of choices. Unavailable commands appear 
dimmed. 

To choose one of the commands listed on a menu, click it. 

Tip: If available, a keyboard shortcut appears next to the command. For example, press F11 to 
maximize the screen to full view or to restore down from full-screen mode. 



 

 

 

Related Topics 

Interaction Desktop interface 

Quick Keys 

You can configure personal keyboard shortcuts and use them to navigate from one workspace or view to 
another: 

• Assign a shortcut to a workspace or view 

• Use shortcuts 

• Display shortcuts 

To assign a shortcut: 

1. Select Window > Quick Keys. 

The Quick Keys dialog box appears. It lists all the views and workspaces in your Interaction 
Desktop. If you have more than one workspace, by default, Interaction Desktop assigns a shortcut 
to each workspace. You can change these shortcuts. 



 

 

 

2. To change the default key assignment for a workspace, select the Override default Workspace 
behavior checkbox. 

3. Select a workspace or view and from the Quick Key drop-down list, select a set of shortcut keys. 

Tip: Each shortcut must be unique. 

4. Click OK. 

To use a shortcut: 

Just type the quick key combination whenever Interaction Desktop "has focus;" that is when it is the 
application you are currently using. 

  

To display shortcuts: 

• Point to a workspace or view tab to display a tooltip containing the Quick Key shortcut. 

• Shortcuts are also listed on the Workspaces menu and the Window menu (for views). 

Modules 

Module licensing 

The Module Management dialog lists currently installed application modules, provides licensing details, 
and shows you whether a module is available or not. Your company must have appropriate licenses to 
work with specific application modules. Your Customer Interaction Center (CIC) administrator assigns 

licenses in Interaction Administrator. 

If Interaction Desktop detects a licensing issue, a warning icon appears in the lower right corner of the 
Interaction Desktop window. For example, a warning could appear if all the licenses for a particular 



 

 

module are in use or if you are using the license on a different workstation. This warning icon can also 
indicate that an error occurred while Interaction Desktop tried to acquire the license. 

To open the Module Management dialog, click the warning icon. An application with a licensing issue 
appears in the modules list accompanied by a warning icon and a description of the issue. 

Related Topics 

Modules 
View modules and licensing 

View modules and licensing 

The Module Management dialog lists currently installed application modules, provides licensing details, 
and shows you whether an application module is available or not. 

• To view a list of modules and licensing details, click Tools > Module Management. 

 

  

Related Topics 

Modules 
Module licensing 

Toolbars 

Show or hide a toolbar 

The toolbar area in the Interaction Desktop interface contains several smaller toolbars that you can 
display or hide. 

 



 

 

  

1 Standard toolbar Add new views or workspaces to Interaction Desktop. Use the 
standard editing tools for cut, copy, paste, and delete in text boxes. 

2 Status toolbar View or change your Customer Interaction Center (CIC) status. This 
toolbar also displays how long you have spent in your status. You can 

add status notes to provide more information about your status. 

3 Workgroup 
Activation 

toolbar 

Select or clear activation status check boxes for the workgroups to 
which you belong. 

4 Make Call 
toolbar 

Call by typing a phone number. Lookup and dial a number from your 
Company Directory by typing part of the contact’s name. Or, click the 
drop-down arrow to choose from a list of names and numbers you 
have recently called. 

5 Processes 
toolbar 

Search for and start an Interaction Process. 

  

To display a toolbar, right-click in the Interaction Desktop toolbar and click the name of the toolbar you 
want to display. 

Tip: A check mark appears for a displayed toolbar. 

• To hide a toolbar, right-click the toolbar and then click to remove the check mark before the 

name of the toolbar. 

Tip: You can also click View > Toolbars to display or hide selected toolbars. 

Related Topics 

Interaction Desktop interface 
Toolbars 

Navigation pane 

Dock the Navigation pane 

To dock the Navigation pane and return it to the original state, click View > Navigation pane > Normal. 

Related Topics 

Automatically hide the Navigation pane 
Hide the Navigation pane 
Minimize the Navigation pane 
Navigation pane 



 

 

Minimize the Navigation pane 

When you minimize the Navigation pane, you pin its slim profile along the left side of the Interaction 
Desktop window, providing quick access to the Navigation pane. 

Tip: To display the Navigation pane temporarily, pause the mouse pointer over the minimized 
Navigation pane tab. The Navigation pane expands. You automatically minimize it when you move 

your mouse pointer away from the pane. 

To minimize the Navigation pane, do one of the following: 

• Click View > Navigation pane > Minimized. 

• Click the Navigation Pane drop-down menu and select Auto Hide. 

• In the Navigation Pane title bar, click the Auto Hide pin.  

 

Note: To restore the Navigation pane to its original state on the left side of the window, pause 
over the minimized Navigation pane tab. When it expands, click the Auto Hide pin. 

Related Topics 

Automatically hide the Navigation pane 
Dock the Navigation pane 
Hide the Navigation pane 
Navigation pane 

Hide the Navigation pane 

To increase the area of the workspace in the window, you can hide the Navigation pane. There are 
several ways to minimize and expand the Navigation pane. Choose the one that best fits your working 
style.  You can also move the Navigation pane to a new location in the workspace. 

To turn off and hide the Navigation pane, do one of the following: 

• Click View > Navigation pane > Off. 

• Click the Navigation pane drop-down menu and select Hide. 

 

• In the Navigation pane title bar, click the X in the upper right corner. 

Note: To display the Navigation pane again, click View > Reset pane layout. 

Related Topics 

Automatically hide the Navigation pane 
Dock the Navigation pane 



 

 

Minimize the Navigation pane 
Navigation pane 

Automatically hide the Navigation pane 

To hide the Navigation Pane automatically, click View > Navigation pane > Auto. 

Note: This option hides the Navigation pane if it is empty, or keeps it open if it contains navigational 
information for the workspace. 

Related Topics 

Dock the Navigation pane 
Hide the Navigation pane 
Minimize the Navigation pane 
Navigation pane 

Workspaces 

Create a custom workspace 

You can create a custom workspace to contain different views, which you can sort by task. If you no 
longer need or use a custom workspace, you can delete it. 

Note: You cannot delete a built-in workspace. 

To create a custom workspace: 

1. Do one of the following. 

• Click the down arrow to the right of the New button and select Workspace from the 
menu. 

 

• Click Workspaces > Create Workspace. 

2. In the Create New Workspace dialog, in the Name text box, type the title of the workspace. 



 

 

3. In Description, type a short, descriptive summary of the workspace. 

4. From the Icon drop-down list, select an icon to associate with the workspace. This icon appears 
on the workspace tab. 

5. Click OK. 

Result: The Getting Started view appears in a new custom workspace. To remove this view, right-
click the Getting Started tab and select Close View from the menu that appears. 

Note: To prevent the Getting Started view from appearing in new custom workspaces, clear the 
Show "Getting Started" check box on the Getting Started view. 

Related Topics 

Add a view to a workspace 
Create a custom workspace 
Delete a custom workspace 

Delete a custom workspace 

You can delete a workspace that you create. You cannot delete a built-in workspace. 

To delete a custom workspace: 

1. Open the custom workspace you want to delete. 

2. From the Workspaces menu, choose Delete Workspace. 

3. In the "Delete Workspace?" dialog box, click Yes. 

Related Topics 

Create a custom workspace 
Workspaces 

Display a workspace in full screen mode 

In full screen mode, a workspace fills the entire screen. Toolbars, menus, and other non-essential 
controls do not appear. This feature is helpful in environments that require overhead displays and 
general monitoring. 

To display a workspace in full screen mode: 

1. Do one of the following: 

2. Click View > Full Screen. 

3. Press the F11 shortcut key. 

Result: The workspace expands to cover the entire screen. 

4. To hide the Navigation pane, click View > Navigation Pane > Off. 

Related Topics 

End full screen mode 
Start a workspace slide show 



 

 

Workspaces 

End full screen mode 

To restore a workspace to its original size and end full screen mode: 

1. Do one of the following: 

• Pause the mouse pointer at the top of the screen and display the menu bar. Click the 

Full Screen button. 

• Press the F11 shortcut key. 

Result: The workspace returns to its original size. 

2. To display the Navigation pane on the left, click View > Navigation Pane > Normal. 

Related Topics 

Display a Workspace in full screen mode 
Start a workspace slide show 
Workspaces 

Start a workspace slide show 

You can configure a workspace to continuously cycle through open tabbed views at 5-second intervals. 
Slide show mode makes it easy to monitor multiple views using an overhead monitor or kiosk. Before 
setting up a slide show, dock the views so they are in a tabbed arrangement. 

To start a workspace slide show: 

1. Open the workspace that contains the views you want to rotate. 

2. Click View > Show slide show. 

Result: The Show Slide Show button appears on the menu bar. 

Tip: To end the slide show, click the Show Slide Show button again. 

Related Topics 

Arrange views in a workspace 
Workspaces 

Workspace tabs 

Workspace tabs, located to the left of the Navigation pane, provide centralized navigation to module 
components, which display their views in workspaces. You can add or remove custom workspaces, and 
you can change the display order of the buttons. 

Note: You cannot delete or rename built-in workspaces. 

Related Topics 

Add a custom workspace 
Change tab order in the Workspaces pane 
Delete a custom workspace 



 

 

Workspaces 

Change tab order in the Workspaces pane 

You can change the order of the tabs in the Workspaces pane. 

To change the workspace tab order: 

1. Click Workspaces > Reorder workspaces. 

2. In the Reorder Workspaces dialog box, select a workspace and click the up or down arrows to 
move the workspace to a new location in the list. 

 

3. Click OK. 

Related Topics 

Interaction Desktop interface 
Workspace tabs 
Workspaces 

Views 

Add a view to a workspace 

You can add views to built-in or custom workspaces. The selections available for a particular module 
determine the available views for built-in workspaces. You can add views to custom workspaces, 
according to your needs. You can also add views from different modules to a custom workspace. 

1. Open the workspace to which you want to add a new view and do one of the following: 

• Click File > New > View. 

• Click the down arrow to the right of the New button and select View. 

• Press the shortcut keys Ctrl+Shift+N. 

• Right-click a tab or next to a group of tabs in the area where you want to add a view and 
click New view. 



 

 

• Click Options > Configuration. In the Views properties details pane of the Configuration 
dialog box, click New View. 

 

• Press the shortcut keys Ctrl+Shift+N. 

Result: The Create New View window opens. 

 

2. To select the grouping of views in the Create New View dialog box, do one of the following: 

• To group the available views according to the active modules in Interaction Desktop, 

click the Group by drop-down list and select Products. 



 

 

• To display available views by category (Agents and Workgroups, Directories, Queues, 
and others), click the Group by drop-down list and select Categories. 

3. To select how the views are displayed in the Create New View dialog box, do one of the 
following:  

• To represent views by view name and icon, click the Views drop-down list and select 
Icon View. 

• To display more detail for each view, click the Views drop-down list and select List View. 

Result: The view name, the module to which it belongs, the view’s icon, and a brief 

description of the view appear. 

4. To add the selected view to the current workspace, do one of the following:  

• Double-click the view you want to add to the workspace. 

• Select the view you want to add to the workspace and click OK. 

Note: Depending on the selected view, Interaction Desktop prompts you through configuration 
options before adding the new view to the workspace. For more information, see the help for the 

appropriate module. 

Related Topics 

Arrange views 
Close a view 
Rename a view 
Views 

Add or remove view columns 

Requirements: In CIC client views, the Customize Client Security Right enables you to add or remove 
view columns. The View Directory Status Columns Access Control right determines which Status 
columns you can add to a directory view. The View Queue Columns Access Control right determines 

which columns you can add to a queue view. 

Right-click a column label in a queue or directory to display a menu of the columns that can be added or 

removed. 

To add or remove a column: 

1. Right-click on the column headings for the view. 

Result: A drop-down list of available column names appears. 

2. Do one of the following: 

• To add a column, click the name of a column. 

• To remove a column, click the name of a column with a check mark. 

Close a view 



 

 

You can close a single view, or you can close all views in a custom workspace. The ability to close a 
specific view varies depending on the module in the workspace. In the future, if Interaction Desktop has 

built-in workspaces, you can close any non-required view. 

Note: Closing a view does not delete it from Interaction Desktop. You can add the same view back to 
a workspace. However, Interaction Desktop discards any customizations you made to the view, such 
as adding or removing columns. 

To close one view, do one of the following: 

• Right-click the tab for the view you no longer want to display and select Close view. 

• Select the tab for the view and click Window > Close view. 

To close all the views in a workspace, do one of the following: 

• Right-click any tab in the Workspace and select Close all views. 

• Click Window > Close all views. 

Related Topics 

Add a view to a workspace 
Views 

Rename a view 

After you add a view to the workspace, you can change the name of the view to distinguish it from 
instances of the same view. For example, you can customize some views by adding or removing columns 
or toolbar buttons or making other changes. You could have several views of the Company Directory, 
each of which displays the same information in a slightly different way or displays only selected 
information. 

To rename a view: 

1. Do one of the following: 

• Right-click the tab that contains the view you want to rename and select Rename. 

• Select the tab for the view and click Window > Rename. 

Result: The Rename View dialog box appears. 

 

2. Click the Use custom title check box, and in the accompanying text box, type a new name for 
this customized view. 

Note: To revert to the default title at any time, clear the Use custom title check box. 

3. Click OK. 



 

 

Related Topics 

Add a view to a workspace 
Arrange views 
Views 

Customize views 

The CIC client help has additional tips and instructions for managing views. 

Related Topics 

Customizing the Interface 

Arrange views 

Docking architecture 

Using a flexible docking architecture, you can arrange views within the Interaction Desktop interface, 
placing them in more convenient locations to suit your needs. This capability is helpful if you manage 

multiple views, such as workgroup overviews. within a workspace 

Note: When you exit Interaction Desktop, it saves the arrangement of your docked views. 

To move a view, click and hold the tab with your mouse and start dragging it. Docking icons appear on 
the Interaction Desktop window, showing you the available locations to which you can move the view. 

When you drag the view on top of an arrow, Interaction Desktop indicates the area to which the view 
moves when you release your mouse and "drop" it. You can also drag a view within its current set of 

tabs to reorder it. 



 

 

 

1 Selected view To move a view, click and hold on its tab and start dragging it. 

2 Selected docking 
zone 

When you drag the view on top of an arrow, Interaction Desktop 
indicates the area to which the view moves when you release 
your mouse and "drop" it. 

Tip: You can also drag a view within its current group of tabs 
to reorder it. 

3 Center docking 
icons 

To relocate a view based on the view over which it appears, use 
the center cocking icons 

For example, if you want to move a selected view above another 
view, click and drag the selected view until the center docking 
icons appear. Then position the cursor over the top center 

docking icon and release the mouse button. 

4 Outer docking 
icons 

To move a selected view to an entire workspace zone, use the 
outer docking icons. 

For example, if you want to move a view so that it takes up the 
left side of the workspace, click and drag the view. Position the 



 

 

cursor over the left outer docking icon and release the mouse 
button. 

  

Related Topics 

Arrange views 
Arrange views in a workspace 
Create groups of views 

Arrange views in a workspace 

You can arrange views in a workspace, placing them in locations that better suit your needs. 

Note: When you exit Interaction Desktop, it saves the arrangement of your docked views. 

To move a view to a new location: 

1. Open the appropriate workspace. 

2. Click and hold the tab of the view you want to move. 

Result: The docking icons appear. 

3. Without letting go of the mouse button, move the cursor over the icon that represents where 
you want to move the View. 

Note: Interaction Desktop indicates the selected area. 

4. To drop the view into its new location, release the mouse button. 

Result: The view automatically moves to the chosen location. 

Related Topics 

Arrange views 
Create groups of views 
Display a view in a floating window 
Docking architecture 
Resize a view 

Display a view in a floating window 

You can position floating views anywhere on the screen, even outside the Interaction Desktop window. 
You can click and drag any tab off the Interaction Desktop window so that it becomes its own separate 
window and remains on top of the main window. If you exit or minimize Interaction Desktop, the 
floating window also closes or minimizes. 

Note: Floating windows are workspace-specific. If you switch to a different workspace, Interaction 
Desktop hides the current set of floating windows and displays floating windows for the new 
workspace. 

If you exit an instance of Interaction Desktop that contains a floating window, when you log back on the 
floating window opens with the same size and position. If the floating window was partially off-screen 
when you exited Interaction Desktop, the system repositions it so that the entire view opens on the 



 

 

screen. Repositioning sometimes occurs when you use a second monitor or connect remotely to a 
workstation with two monitors. 

To display a view in a floating window: 

1. Click the tab of the view you want to float. 

2. Drag the floating window anywhere you like. 

3. Resize the window, as needed. 

Related Topics 

Arrange views 
Arrange views in a workspace 
Create groups of views 
Docking architecture 
Resize a view 

Create groups of views 

You can position docked views several different ways. You can place your views into a horizontal group, 
a vertical group, or a tabbed group. Choose the arrangement that best suits your needs. 

Note: In addition to arranging views into groups, you can resize them to fit the workspace. 

You can make groups of views in any of the following ways: 

• Click a tab for a view you want to place into a horizontally tabbed view and from the Window 
menu select New horizontal tab group (). 

• Right-click a tab for a view you want to place into a horizontally tabbed view and select New 
horizontal tab group  from the menu that appears. 

• Click a tab for a view you want to place into a vertically tabbed view and from the Window 
menu select New vertical tab group. 

• Right-click a tab for a view you want to place into a vertically tabbed view and select New 
vertical tab group () from the menu that appears. 

• Select the tab for the view you want to move to a tabbed group, and from the Window menu 
select Move to previous tab or Move to next tab. 

• Right-click the tab for the view you want to move to a tabbed group and select Move to 
previous tab or Move to next tab from the menu that appears. 

Related Topics 

Add a view to a workspace 
Arrange views 
Docking architecture 

Resize a view 

To change the width, point to the left or right area between the views. When the pointer changes into a 

resize cursor (as indicated by ), drag the border to the right or left. 



 

 

To change the height, point to area between the center views. When the pointer changes into a 

resize cursor (as indicated by ) drag the border up or down.   

Related Topics 

Arrange views in a workspace 
Create groups of views 
Display a view in a floating window 
Views 

Change log 

Date Changes 

27-January-
2016 

Documented context menu option for adding a new view in the client. Updated 
Add a view to a workspace,  

07-September-
2016 

Documented ForceCorrectTabOrder in parameters table in Command Line 
Parameters topic. 

11-October-
2017 

Rebranded documentation to reflect Genesys logo and product terminology and 
names. 

26-October-
2018 

In Answer the first call to a remote location topic, added dropdown text defining 
“campaign calls.” 

13-February-
2019 

Reinforced contacting the CIC administrator if user has forgotten password by 
adding Note to beginning of Logon Connection Settings topic. 

15-March-2019 Created this change log. 

21-March-2019 Added Note about contacting CIC administrator to Change password topic. 

08-August-2019 Added accessibilitycompliant to Command line parameters topic. 

 

 


