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Accessibilty Compliance

Technical Reference

Abstract

This technical reference is a general guide for configuring Interaction
Desktop to comply with Section 508 standards. Accessibility compliance
also includes enhancements based on AODA-UK (Accessibility for
Ontarians with Disabilities Act) guidelines. Each business's
implementation is unique therefore compliance may require
configuration changes that fit your specific environment or users.

For the latest version of this document, see the PureConnect
Documentation Library at: http://help.genesys.com/cic.

For copyright and trademark information, see
https://help.genesys.com/cic/desktop/copyright_and_trademark_information.htm.
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Accessibility Compliance Guide

Introduction
We tested PureConnect Interaction Desktop, using the Department of Homeland Security Compliance Test Processes and Tools.
See https://www.dhs.gov/compliance-test-processes and https://www.dhs.gov/508-tools.

Note: This document reflects Interaction Desktop accessibility compliance as of version 2019 R3. Earlier versions meet the
absolute minimum ADA Rule 508 standards and capabilities. Some customers may find earlier versions unsatisfactory for
their use. Accessibility enhancements based on AODA-UK (Accessibility for Ontarians with Disabilities Act) guidelines first
appeared in 2019 R3. Genesys has tested only Interaction Desktop for compliance. We have not tested any other ancillary
applications.

Administrators must create workgroups and configure client templates for users who require settings that meet 508 Compliance
standards. Templates also enable ease of deployment for users who require the accessibility enhancements based on AODA
guidelines.

Setup Overview
1. Create an Accessibility Compliance Workgroup or Workgroups depending on your organizational needs.
2. Create Interaction Desktop Workspace Template or Templates.
3. Apply the Interaction Desktop Workspace Template or Templates created in Interaction Administrator.
4. Optionally, add the accessibilitycompliant=true server parameter.
5. To support text-to-speech output, install the JAWS screen reader on each applicable workstation. Users must start the JAWS

screen reader before starting Interaction Desktop.

Note: The JAWS computer screen reader is a licensed, third-party application that is not included with Interaction Desktop.

Copyright and trademark
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Accessibility Parameter
To take advantage of optional accessibility compliance enhancements based on AODA-UK guidelines, use the
accessibilitycompliant=true command line parameter or server parameter.

You can set the server parameter in Interaction Administrator or supply your users with a command line argument. Server
parameters affect all Interaction Desktop users in all future sessions. You use a command line argument when starting Interaction
Desktop, typically in a Windows shortcut. A command line argument affects only the current user in the current session.

Note: The command line argument overrides the server parameter setting.

Example: "C:\Program Files (x86)\Interactive Intelligence\ICUserApps\InteractionDesktop.exe" -
accessibilitycompliant=true
When you set accessibilitycompliant to true:

Enabled toolbar button names appear in high contrast, making them easier to see and read.
The screen reader fully describes a selected interaction (name, number, state, and so on.).
Note: Accessibilitycompliant defaults to "false." In that case, the screen reader describes a selected interaction only by number;
for example, 1 of 3.

If a search fails to find matching records, the screen reader announces that no records were found.
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Workgroups
Create one or more workgroups for users with disabilities. Administrators can then ensure consistency across the application and
in training with the use of Shortcut Keys and Quick Keys.

Note: You need multiple workgroups if users with disabilities are in different departments or other administrative groups.

Create an Accessibility Compliance Workgroup

Create an Accessibility Compliance Workgroup
1. In the Workgroup area, right-click and select New.

2. In the Entry Name box, type a workgroup name that identifies the users as well the area to which you assigned them.
In this example, the new Workgroup is Call Center Accessibility Users.

3. Follow the instructions in the Interaction Administrator help to configure the organization.
4. Add the appropriate users to this workgroup.
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Client Templates
Before deploying for accessibility compliance, administrators must create client templates. Client templates ensure consistent
Interaction Desktop configuration across all accessibility compliant workgroups. Administrators use Interaction Desktop to create
client templates and Interaction Administrator to deploy these templates to selected workgroups.

Warning: If you require users to make these changes themselves, Interaction Desktop configuration and option settings may
not be accessibility compliant.

Create an Accessibility Compliance Template

Apply the Interaction Desktop Workspace Template

Accessibility Compliance Guide

Create an Accessibility Compliance Template
Requirements: The Interaction Desktop user must have a Client Access license, the Manage Client Templates Security right, and
the Customize Client Security right.

Note: Depending on your organization, you may need multiple templates to match the various roles of users with disabilities.
Repeat these instructions for each template needed.

1. Log on to Interaction Desktop.
2. Select File > Templates > Enter Template Mode.

3. Select Workspaces > Create workspace.

4. In the Create New Workspace dialog, give the Workspace an appropriate Name, Description, and Icon, then click OK.

6



5. If the Getting Started view appears in your new custom workspace, right-click its tab and select Close View from the menu that
appears.

6. Add views to the template.
Add the views required for users’ everyday tasks to this new workspace. These views include queues and directories to which
they need access. In this example, My Work Items, My Interactions, Dial Pad, and Company Directory appear in the Accessibility
Compliance workspace.
Tip: For more information about adding views, changing view layout, customizing columns, and customizing toolbars, see the
Interaction Desktop help.

7. Select Windows > Quick Keys.
After you create your workspace and add views, assign Quick Keys to your views and workspace to allow easy navigation.
Assigning Quick Keys is an important part of accessibility compliance. Quick Keys give users access to the application without
requiring interaction with the mouse. Interaction Desktop also includes Shortcut Keys.
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8. In the Quick Keys dialog, assign Quick Keys to the workspace and the views, then click OK.

Tip: For more information about Quick Keys, click the help icon in the dialog box or see Getting Started on the
Interaction Desktop Help menu.

9. To set client configuration options, select Options > Configuration.
Client templates can include option settings for Alerts, Calls Configuration, IP Phone and more. For more information, see
Configuration Options in the Interaction Desktop help.
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10. Select File >Templates > Save Current Template As.

11. Give the template an appropriate, easily identifiable name.
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12. Click Save.
13. Select Exit Template Mode.

Copyright and trademark

Apply the Interaction Desktop Workspace Template
After you create your workgroups and workspace templates, apply the template to the workgroup.
1. In Interaction Administrator, select People > Client Templates.
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2. Click Select Workgroups.
3. Select and add the workgroup you created for users with disabilities.

4. In the Select a template to apply section, select the appropriate template.

11



5. Click Apply Template.
Result: A confirmation message appears.
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Interaction Desktop Shortcut Keys
Interaction Desktop includes many pre-programmed Shortcut Keys.

Tip: The Shortcut Keys topic in the Interaction Desktop help also contains a complete list of these shortcuts.

My Interactions and Other Queue Shortcuts

Directory Shortcuts

Command and menu shortcuts

My Interactions and Other Queue Shortcuts
Interaction shortcuts work only if you first select an interaction to ensure it has focus.

Tip: To display a menu that lists these shortcuts, right-click an interaction.
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Function Shortcut

Call Back Ctrl+B

Coach Ctrl+O

Create Custom Call Rule Ctrl+Shift+C

Always send caller directly to voice mailCtrl+Shift+M

Disconnect Ctrl+D

Hold Ctrl+H

Join Ctrl+J

Listen to a Call Ctrl+L

Mute Call Ctrl+U

Park on Orbit Ctrl+K

Pause Recording Ctrl+E

Pickup Ctrl+P

Private Ctrl+I

Properties Ctrl+Shift+P

Record Ctrl+R

Remove from Queue Ctrl+Shift+R

Request Assistance Ctrl+N

Secure Input Ctrl+V

Secure Record Pause Ctrl+Shift+E

Send to Voicemail Ctrl+M

Snip Ctrl+Shift+S

Transfer Ctrl+T

Whisper Ctrl+W

 

Directory Shortcuts
Directory shortcuts work only if you first select a directory entry. Specific directory shortcuts are available only if the directory entry
includes the necessary information or if the function is available. For example, the shortcut for dialing an assistant is not available
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if the selected directory entry does not have the assistant’s number. And if the agent doesn’t have the Change Status Users access
control right, change user’s status is not available.

Tip: To display a menu that lists these shortcuts, right-click an interaction.

Function Shortcut

Camp Ctrl+A

Change user’s status Ctrl+S

Copy Ctrl+C

Dial Assistant Ctrl+R

Dial Business Phone Ctrl+B

Dial Business number 2 Ctrl+U

Dial Default number Enter

Dial Extension Ctrl+Shift+X

Dial Fax Ctrl+F

Dial Home Ctrl+H

Dial Home 2 Ctrl+O

Dial Mobile Phone Ctrl+I

Dial Pager Ctrl+G

Send Email (Business) Ctrl+E

E-mail message to Home addressCtrl+L

Initiate new Chat Ctrl+Shift+C

Properties Ctrl+Shift+P
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Command and menu shortcuts
This table lists Interaction Desktop command and menu shortcuts.

Function Shortcut

Active camps Alt+T+A

Change Password Alt+F+P

Change Station Alt+F+S

Close (hide) Interaction Desktop Alt+F4

Close currently selected view Alt+W+C

Close all views in current workspace Alt+W+L

Configuration Alt+O+C

Copy Ctrl+C

Create a new View Ctrl+Shift+N

Create a new Workspace Alt+R+C

Cut Ctrl+X

Delete Delete

Delete the current Workspace Alt+R+D

Dock Navigation Pane in original location Alt+V+N+N

Edit the current Workspace Alt+R+E

Exit Alt+F+X

Full Screen toggle F11 or Alt+V+U

Hide Navigation Pane automatically if emptyAlt+V+N+A

Log off Alt+F+O

Mini Mode toggle F5

Minimize Navigation Pane Alt+V+N+M

Paste Ctrl+V

Reorder Workspaces Alt+R+R

Response Management Alt+T+R

Rules Alt+O+R

Status Bar toggle Alt+V+S
16



Time-Off Requests Alt+Z+O

Toolbar selection Alt+V+T

Tracker menu Alt+K

Turn off and hide Navigation Pane Alt+V+N+O

Workgroup Activation Alt+O+W
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Change Log
The following table lists the changes to this document since Customer Interaction Center version 4.0 product availability.

Date Change

10-June-2019 Converted to HTML format and added to PureConnect Documentation Library.

11-July-2019 Fixed multiple broken hyperlinks in My Interactions and Other Queue Shortcuts topic and the Directory Shortcuts
topic.

09-August-2019 Edited to include information on Accessibility enhancements based on AODA-UK (Accessibility for Ontarians
with Disabilities Act) guidelines.

18


	Table of Contents
	Introduction
	Setup Overview

	Accessibility Parameter
	Workgroups
	Create an Accessibility Compliance Workgroup

	Client Templates
	Create an Accessibility Compliance Template
	Apply the Interaction Desktop Workspace Template

	Interaction Desktop Shortcut Keys
	My Interactions and Other Queue Shortcuts
	Directory Shortcuts
	Command and menu shortcuts

	Change Log

