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Salesforce Object Routing Server
Troubleshooting the Salesforce Object Routing Server
Salesforce Object Routing Server Status Dashboard
The dashboard webpage enables you to monitor the Instance status of Salesforce object routing servers (SORS) running for different tenants. You can configure this dashboard to monitor SORS status for multiple tenants. The Heartbeat port should be the port number configured at the logon page for the SORS instance. This dashboard features the copy of the currently configured table and saves it in a plain text file. Administrators can set up the configuration in a particular JSON format text file. A green circle indicates a running server; a red circle indicates a stopped server.
The dashboard webpage file location is "[InstalledPath]/Dashboard/index.html".
Running behind proxy server
The service automatically detects the Windows proxy server settings configured in Windows server and send each request through proxy server. SORS instance should be restarted if proxy server configurations are changed in the Windows server.
Windows Event Logs
SORS instance will generate several Windows event logs for few scenarios related to connection success, failure and reconnection with Salesforce and IC server. Customers and PCC environment monitoring applications can use these Windows event logs. Some of the event data messages include:
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Successfully connected to Primary CIC server
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Logged in successfully to Salesforce
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Error:503: Connecting to alternate CIC Server
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Failed to connect to IC server
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Re-logging to Salesforce
Logs
The Logs path is based on the Windows environment variable ININ_TRACE_ROOT. If ININ_TRACE_ROOT is not defined, the default path would be "[InstalledPath]/logs/application-%DATE%.log". The logs are created on daily basis and older logs are removed based on elapsed days
General Notes
If the SORS instance process is terminated or killed, pm2 automatically starts the SORS instance. All the CIC server workgroups with the ACD email routing flag set to True will subscribe after the successful connection to the Primary IC server. The Salesforce Object Routing Server supports Off-Host Session Manager and Switchover environments.
When the SORS instance starts, it logs in to the CIC server and Salesforce. Then it scans the Salesforce object routing table for un-routed Salesforce case objects and processes the unrouted cases.
Email interactions stop routing
Problem
Push Notifications for the Salesforce Console do not work after deploying the Salesforce Console app in the target org or in a refreshed sandbox.
Causes
Emails stop routing after sandbox refresh because Push Notification Objects and Fields in Console configuration are not copied when deploying a Console app or when refreshing a sandbox. No notification means that the connector never hears about the new salesforce objects.
Solution
You can recreate the Push Notifications by following these steps:
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From Setup, enter Apps in the Quick Find box, then select Apps.
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Select the name of a Console App.
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Select Select objects and fields for notifications next to Choose Push Notifications.
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In the Push Notifications page, click Edit.
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In the Choose objects for push notifications list, select ININ Object Routing Queues.
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In the Choose fields for push notifications section, select Edit.
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Add all Available Items to the Selected Items list and click OK.
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In the Push Notifications page, click Save.